Error: "Your TestFit license has expired. Log into the license portal or contact TestFit support to renew your license"
When signing into TestFit Urban Planner, you get "Your TestFit license has expired. Log into the license portal or contact TestFit support to renew your license"
Issue
Cause
The happens to user's who've previously had a trial of TestFit that expired before March 1st, 2024. Even if you've signed up for Urban Planner after March 1st, TestFit is still seeing the old trial license, thus triggering the error.
Solution
At this time, the solution is to use "Launch Urban Planner" when signing into TestFit, and then fill out the accompanying form.
NOTE: You will need to do this every time you want to log into Urban Planner.