Error: "Auth0 request failed"

"Initiating the Auth0 authentication process failed with the following error: "Code 500" Please contact our support team for assistance"


Issue

When logging into the TestFit application you get the following error:

"Auth0 request failed

Initiating the Auth0 authentication process failed with the following error: "Code 500"

Please contact our support team for assistance"

image-Aug-01-2023-05-35-19-9270-PM (1)

IMG_20240105_081647


Cause

While we haven't found the root cause, generally it's due to a communication issue between the workstation and our services.


Solution

The following domain and IP address should be whitelisted to ensure license checks and software updates work properly.

  • Domains:
    • TestFit.io
    • portal.testfit.io
    • auth.testfit.io
  • IP Address: 165.22.6.27